Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Caterpillar Script Error
#1
Hey Guys, i've been using RMXP for quite some time now and my project is going well, but one simple script is causing me some trouble and seriously endangering the playability of my game.
The Caterpillar Script by Fukuyama

The Problem:
In Battle, when one of my characters dies, i will get an error saying "comparison float with float failed" (or something like that) on line 184
which is
Code:
case @move_list[i].type
i guess that it tries to display something during battle which it should only on the map...oO
Note: This doesnt happen everytime a character dies, just randomly.
Please Help.
Reply }
#2
Erm... Glad to see you're as confused as I am. It shouldn't even bring that line up or access map character functions in the battlesystem. Confused

What battlesystem are you using?
Reply }
#3
the default one...
just some simple add ins:
XRXS's Full-View Battleback & Movable Camera ver.2
and
KGC_EquipLearnSkill
+ KGC_PreemptAttack

these are the only scripts i'm using that affect the battlesystem...afaik...
the problem is, that this error isnt really reproducable. i spent the last hour to get it again but it didnt even occur once. i did not change anything during that time.
its just really random...
Reply }
#4
Confused And none of those even touch the Game_Map or Scene_Map or Game_Party code...
Reply }
#5
i just got the error again, this time it happened in the middle of a battle, no one died. it happened just before the execution of a skill.

this is a screenshot of the message:
[Image: errorpj.th.jpg]

would it somehow be possible to disable the whole caterpillar script upon the start of the battle scene?

Edit:
uhh.. now i get the same error but elsewhere...in MAIN oO
[Image: error2mv.th.jpg]

my main looks like this:
Code:
#==============================================================================
# ** Main
#------------------------------------------------------------------------------
#  After defining each class, actual processing begins here.
#==============================================================================

begin
  # Prepare for transition
  Graphics.freeze
  $defaultfontface = "Tahoma"
  $defaultfontsize = 24
  # Make scene object (title screen)
  $scene = Scene_Title.new
  #Scene_Movie.new("tis")
  #Scene_Movie.new("intro")
  # Call main method as long as $scene is effective
  while $scene != nil
    $scene.main
  end
  # Fade out
  Graphics.transition(20)
#rescue Errno::ENOENT
  # Supplement Errno::ENOENT exception
  # If unable to open file, display message and end
# filename = $!.message.sub("No such file or directory - ", "")
  #print("Unable to find file #{filename}.")
end
Reply }
#6
That main script let us think you're using a Postality Knights XP version... Have you tried to use the caterpillar script in the legal version of XP?
"For God has not destined us for wrath, but for obtaining salvation through our Lord Jesus Christ," 1 Thessalonians 5:9

Maranatha!

The Internet might be either your friend or enemy. It just depends on whether or not she has a bad hair day.

[Image: SP1-Scripter.png]
[Image: SP1-Writer.png]
[Image: SP1-Poet.png]
[Image: SP1-PixelArtist.png]
[Image: SP1-Reporter.png]

My Original Stories (available in English and Spanish)

List of Compiled Binary Executables I have published...
HiddenChest & Roole

Give me a free copy of your completed game if you include at least 3 of my scripts! Laughing + Tongue sticking out

Just some scripts I've already published on the board...
KyoGemBoost XP VX & ACE, RandomEnkounters XP, KSkillShop XP, Kolloseum States XP, KEvents XP, KScenario XP & Gosu, KyoPrizeShop XP Mangostan, Kuests XP, KyoDiscounts XP VX, ACE & MV, KChest XP VX & ACE 2016, KTelePort XP, KSkillMax XP & VX & ACE, Gem Roulette XP VX & VX Ace, KRespawnPoint XP, VX & VX Ace, GiveAway XP VX & ACE, Klearance XP VX & ACE, KUnits XP VX, ACE & Gosu 2017, KLevel XP, KRumors XP & ACE, KMonsterPals XP VX & ACE, KStatsRefill XP VX & ACE, KLotto XP VX & ACE, KItemDesc XP & VX, KPocket XP & VX, OpenChest XP VX & ACE
Reply }
#7
this main script is actually from my legal version. the entries like the $defaultfontface are for compatibility reasons since i'm using some very very old scripts (i've been working on this project for +-5 years now, maybe even longer).
is there a way to prove that im not usingra0a cracked version?
Reply }
#8
Actually, your error messages screenshots do not show invalid or '?' replacement characters which would show up if you were using Postality Knights. Postality's was still set up in its .dlls and related programming to use the Japanese fonts and would show oddly. So, your error messages make me believe it's legit.
Reply }
#9
great.
so, is there anything i can provide to help you get behind my problem?
i tried to disable the "buggy" part of the script by using game switches which would be activated before battle but the error just popped up in main...
my scripting skills and my understanding of ruby are very limited...
Reply }
#10
The switch only makes the trailing characters visible/invisible on the map. Technically, it is always in play.

Perhaps you can provide a demo with the related scripts. Nothing entirely massive (you won't need any MP3s right?). Just something so someone can take a look and see about finding the problem.
Reply }


Possibly Related Threads…
Thread Author Replies Views Last Post
   Script compatibility help Lord Vectra 3 3,944 07-25-2021, 11:42 PM
Last Post: DerVVulfman
   Adding face script on Cogwheel's RTAB Battle Status rekkatsu 15 14,021 08-25-2020, 03:09 AM
Last Post: DerVVulfman
   "Wait" in the script Whisper 13 14,607 04-28-2020, 04:06 PM
Last Post: Whisper
   Skill Cooldown script Fenriswolf 11 14,959 12-10-2019, 11:10 AM
Last Post: Fenriswolf
   (RMVXace) Battle error with Tankentai's battle system, help. x( Starmage 0 3,641 02-14-2018, 04:25 PM
Last Post: Starmage
   Help iwth script (RGSS Player crash) Whisper 3 7,941 06-17-2017, 05:03 PM
Last Post: Whisper
   Help modifying a script Keeroh 7 9,497 06-11-2017, 04:43 PM
Last Post: DerVVulfman
Question  Mog Menu script: help me stop the crazy picture movement during transitions Zachariad 4 9,106 05-31-2017, 05:10 AM
Last Post: Zachariad
   Actor names in Quest Script jreagan406 5 8,001 03-07-2017, 08:06 AM
Last Post: JayRay
  Expiration States with Atoa acbs: error Noctis 5 8,531 02-18-2017, 01:10 AM
Last Post: DerVVulfman



Users browsing this thread: